What’s Vulnerable › Vulnerabilities
CVE-2026-74785: Scriban before 7.0.0 Denial of Service via Unbounded Resource Consumption
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-16 · updated 2026-08-31
- Weakness: CWE-400
Description
Scriban before 7.0.0 contains three distinct denial-of-service vulnerabilities in expression evaluation that bypass existing safety controls through unbounded string multiplication, uncontrolled BigInteger shift operations, and LoopLimit bypass via range enumeration in builtin functions. Attackers who can supply templates can cause out-of-memory exceptions or CPU exhaustion, typically terminating the entire host process.
Affected products
- scriban: before 7.0.0 — fixed in 7.0.0
How to fix
Upgrade to a fixed version: scriban 7.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/scriban/scriban/security/advisories/GHSA-xw6w-9jjh-p9cr
- https://www.vulncheck.com/advisories/scriban-before-denial-of-service-via-unbounded-resource-consumption
- https://github.com/scriban/scriban/security/advisories/GHSA-xw6w-9jjh-p9cr
Get alerted when CVE-2026-74785 or the next vulnerability affects your stack