What’s Vulnerable › Vulnerabilities
CVE-2026-74789: Scriban before 7.0.0 LoopLimit Bypass via Built-in Operations
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-16 · updated 2026-08-31
- Weakness: CWE-400
Description
Scriban before 7.0.0 (affected <= 6.6.0) applies its LoopLimit constraint only to script loop statements and not to expensive iteration performed inside built-in operators and functions. As a result, a single expression such as {{ 1..1000000 | array.size }} — or a memory-amplification expression such as {{ 'A' * 200000000 }} — can force large CPU or memory consumption even when LoopLimit is configured to a very small value, resulting in denial of service. Applications that render attacker-controlled templates and rely on LoopLimit for safe execution are affected.
Affected products
- scriban: before 7.0.0 — fixed in 7.0.0
How to fix
Upgrade to a fixed version: scriban 7.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/scriban/scriban/security/advisories/GHSA-c875-h985-hvrc
- https://www.vulncheck.com/advisories/scriban-before-looplimit-bypass-via-built-in-operations
Get alerted when CVE-2026-74789 or the next vulnerability affects your stack