What’s Vulnerable › Vulnerabilities
CVE-2026-74792: Scriban before 7.0.0 Stack Overflow via nested array initializers
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-16 · updated 2026-09-08
- Weakness: CWE-674
Description
Scriban before 7.0.0 (affected versions <= 6.6.0) contains a stack overflow vulnerability in nested array initializer parsing. Deeply nested array initializers recurse through a path (ParseArrayInitializer → ParseExpression → ParseArrayInitializer) that is not covered by the ExpressionDepthLimit counter added in the fix for GHSA-wgh7-7m3c-fx25. An attacker who can supply untrusted input to Template.Parse can trigger an uncatchable StackOverflowException that immediately terminates the process, even with the default ExpressionDepthLimit enabled.
Affected products
- scriban: before 7.0.0 — fixed in 7.0.0
How to fix
Upgrade to a fixed version: scriban 7.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/scriban/scriban/security/advisories/GHSA-p6q4-fgr8-vx4p
- https://www.vulncheck.com/advisories/scriban-before-stack-overflow-via-nested-array-initializers
- https://github.com/scriban/scriban/security/advisories/GHSA-p6q4-fgr8-vx4p
Get alerted when CVE-2026-74792 or the next vulnerability affects your stack