What’s Vulnerable › Vulnerabilities
CVE-2026-74793: justhtml before 3.11.0 XSS via selectedcontent projection
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-23 · updated 2026-10-12
- Weakness: CWE-79
Description
justhtml before 3.11.0 contains a cross-site scripting vulnerability where the default sanitizer bypasses event handler removal in selectedcontent projections. Attackers can inject SVG or MathML elements with event handlers that are cloned and reinserted into output without sanitization, enabling stored or reflected XSS attacks.
Affected products
- EmilStenstrom justhtml: before 3.11.0 — fixed in 3.11.0
How to fix
Upgrade to a fixed version: EmilStenstrom justhtml 3.11.0. Check the vendor advisory for mitigations.
References
- https://github.com/EmilStenstrom/justhtml/security/advisories/GHSA-gjf2-f4jc-69xf
- https://www.vulncheck.com/advisories/justhtml-before-xss-via-selectedcontent-projection
- https://github.com/EmilStenstrom/justhtml/security/advisories/GHSA-gjf2-f4jc-69xf
Get alerted when CVE-2026-74793 or the next vulnerability affects your stack