What’s Vulnerable › Vulnerabilities
CVE-2026-74795: Scriban before 6.6.0 Denial of Service via Uncontrolled Recursion
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-16 · updated 2026-08-31
- Weakness: CWE-674
Description
Scriban before 6.6.0 contains an uncontrolled recursion vulnerability in its recursive-descent parser. The parser does not enforce a default expression depth limit (the ExpressionDepthLimit property in ParserOptions defaults to null/disabled), so an attacker who controls template input can supply a deeply nested template (e.g., thousands of nested parentheses or blocks) that exhausts thread stack space and raises a StackOverflowException. Because a StackOverflowException cannot be caught in .NET, this causes immediate, unrecoverable termination of the hosting process, resulting in a denial of service. Applications that process untrusted or user-supplied templates can be exploited remotely without authentication.
Affected products
- scriban: before 6.6.0 — fixed in 6.6.0
How to fix
Upgrade to a fixed version: scriban 6.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/scriban/scriban/security/advisories/GHSA-wgh7-7m3c-fx25
- https://www.vulncheck.com/advisories/scriban-before-denial-of-service-via-uncontrolled-recursion
Get alerted when CVE-2026-74795 or the next vulnerability affects your stack