What’s Vulnerable › Vulnerabilities
CVE-2026-74797: OpenTofu before 1.11.4 Denial of Service via malicious zip
- Severity: low (CVSS 3.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-16 · updated 2026-10-08
- Weakness: CWE-400
Description
OpenTofu versions before 1.11.4 contain a denial of service vulnerability in the tofu init command when processing maliciously-crafted .zip archives for provider or module packages. Attackers can cause excessive CPU usage by controlling .zip archive content served during dependency installation, degrading system performance and preventing timely completion of the init process.
Affected products
- opentofu: before 1.11.4 — fixed in 1.11.4
How to fix
Upgrade to a fixed version: opentofu 1.11.4. Check the vendor advisory for mitigations.
References
- https://github.com/opentofu/opentofu/security/advisories/GHSA-r92c-9c7f-3pj8
- https://www.vulncheck.com/advisories/opentofu-before-denial-of-service-via-malicious-zip
Get alerted when CVE-2026-74797 or the next vulnerability affects your stack