What’s Vulnerable › Vulnerabilities
CVE-2026-74848: Apache APISIX: Cross-user response poisoning in serverless plugins
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-27 · updated 2026-08-31
- Weakness: CWE-444
Description
Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') vulnerability in Apache APISIX. An attacker could make other clients receive attacker-chosen or other users' responses on serverless-plugin routes. This issue affects Apache APISIX: from 2.12.0 through 3.17.0. Users are recommended to upgrade to version 3.18.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache APISIX: from 2.12.0 before 3.18.0 — fixed in 3.18.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache APISIX 3.18.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/xdgpszmw8dw4wvmfxy043d83m150kx3n
- http://www.openwall.com/lists/oss-security/2026/08/26/12
Get alerted when CVE-2026-74848 or the next vulnerability affects your stack