What’s Vulnerable › Vulnerabilities
CVE-2026-74851: Pods < 3.3.9.1 - Author+ RCE via Shortcode Display Callback
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-26 · updated 2026-08-26
- Weakness: CWE-94
Description
The Pods WordPress plugin before 3.3.9.1 does not correctly compare a display callback against its list of blocked functions, allowing users with the author role and above to execute arbitrary code on the server. Only sites using the restricted display-callback mode are affected, which is the automatic default on installations whose first Pods version predates 3.1.
Affected products
- sc0ttkclark Pods – Custom Content Types and Fields: from 3.1.0 before 3.3.9.1 — fixed in 3.3.9.1
How to fix
Upgrade to a fixed version: sc0ttkclark Pods – Custom Content Types and Fields 3.3.9.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-74851 or the next vulnerability affects your stack