What’s Vulnerable › Vulnerabilities
CVE-2026-74873: openssl_encrypt before 1.4.0 Password Exposure via CLI Argument
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-17 · updated 2026-10-08
- Weakness: CWE-214
Description
openssl_encrypt versions before 1.4.0 expose passwords passed via the --password CLI argument in process listings accessible to all system users. Attackers can read process arguments through ps aux or /proc/[pid]/cmdline to retrieve plaintext passwords and keystore passwords.
Affected products
- jahlives openssl_encrypt: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: jahlives openssl_encrypt 1.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-h3m5-p59h-x88p
- https://www.vulncheck.com/advisories/openssl-encrypt-before-password-exposure-via-cli-argument
Get alerted when CVE-2026-74873 or the next vulnerability affects your stack