What’s Vulnerable › Vulnerabilities
CVE-2026-74875: openssl_encrypt before 1.4.0 Schema Validation Bypass
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-17 · updated 2026-10-08
- Weakness: CWE-345
Description
openssl_encrypt versions before 1.4.0 silently skip JSON schema validation when the jsonschema library is not installed, allowing malformed metadata to be accepted. Attackers can remove the jsonschema package or supply unknown metadata format versions to bypass all schema checks and process malicious data.
Affected products
- jahlives openssl_encrypt: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: jahlives openssl_encrypt 1.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-425g-fjhq-5h92
- https://www.vulncheck.com/advisories/openssl-encrypt-before-schema-validation-bypass
Get alerted when CVE-2026-74875 or the next vulnerability affects your stack