What’s Vulnerable › Vulnerabilities
CVE-2026-74878: openssl_encrypt before 1.4.0 TOTP Rate Limiter Bypass
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-17 · updated 2026-10-08
- Weakness: CWE-770
Description
openssl_encrypt versions before 1.4.0 use an in-memory rate limiter for TOTP brute-force protection that is not shared across workers and is lost on server restart. Attackers can distribute authentication attempts across multiple server instances or retry immediately after a restart to bypass rate limiting protections.
Affected products
- jahlives openssl_encrypt: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: jahlives openssl_encrypt 1.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-h45m-mgcp-q388
- https://www.vulncheck.com/advisories/openssl-encrypt-before-totp-rate-limiter-bypass
Get alerted when CVE-2026-74878 or the next vulnerability affects your stack