What’s Vulnerable › Vulnerabilities
CVE-2026-74882: openssl_encrypt before 1.4.0 Insecure Default Configuration
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-17 · updated 2026-08-31
- Weakness: CWE-345
Description
openssl_encrypt versions before 1.4.0 contain an insecure default configuration that trusts the entire RFC 1918 private address space in IntegrityProxyConfig trusted_proxies. Attackers on private networks can forge client certificate headers to bypass mTLS authentication when ProxyAuth validation is relaxed or modified.
Affected products
- jahlives openssl_encrypt: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: jahlives openssl_encrypt 1.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-2592-7m3g-7fq6
- https://www.vulncheck.com/advisories/openssl-encrypt-before-insecure-default-configuration
Get alerted when CVE-2026-74882 or the next vulnerability affects your stack