What’s Vulnerable › Vulnerabilities
CVE-2026-74884: openssl_encrypt before 1.4.0 Path Traversal via plugin_id
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-17 · updated 2026-09-01
- Weakness: CWE-73
Description
openssl_encrypt versions before 1.4.0 contain a path traversal vulnerability in the _is_safe_path method where the plugin_id parameter is not sanitized before constructing the plugin config directory path. Attackers can declare a malicious plugin_id containing path traversal sequences like '../' to access arbitrary directories outside the intended plugin directory.
Affected products
- jahlives openssl_encrypt: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: jahlives openssl_encrypt 1.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-8jpj-w975-rwv5
- https://www.vulncheck.com/advisories/openssl-encrypt-before-path-traversal-via-plugin-id
Get alerted when CVE-2026-74884 or the next vulnerability affects your stack