What’s Vulnerable › Vulnerabilities
CVE-2026-74889: openssl_encrypt before 1.4.0 Weak Key Derivation via HKDF
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-17 · updated 2026-09-01
- Weakness: CWE-326
Description
openssl_encrypt versions before 1.4.0 use HKDF with no salt and static info parameter in key normalization functions, reducing entropy extraction and determinism. Attackers can exploit predictable key derivation with identical inputs to weaken cryptographic security against multi-target attacks.
Affected products
- jahlives openssl_encrypt: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: jahlives openssl_encrypt 1.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-j9mh-57cc-665x
- https://www.vulncheck.com/advisories/openssl-encrypt-before-weak-key-derivation-via-hkdf
Get alerted when CVE-2026-74889 or the next vulnerability affects your stack