What’s Vulnerable › Vulnerabilities
CVE-2026-74890: openssl_encrypt before 1.4.0 HMAC Authentication Bypass via Environment Variable
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-17 · updated 2026-10-24
- Weakness: CWE-345
Description
openssl_encrypt versions before 1.4.0 contain an authentication bypass vulnerability in CamelliaCipher that disables HMAC tag generation and verification when the PYTEST_CURRENT_TEST environment variable is set. Attackers with code execution can set this environment variable to produce unauthenticated ciphertext and bypass integrity protection on encrypted data.
Affected products
- jahlives openssl_encrypt: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: jahlives openssl_encrypt 1.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-rvc2-5jxq-gpcj
- https://www.vulncheck.com/advisories/openssl-encrypt-before-hmac-authentication-bypass-via-environment-variable
Get alerted when CVE-2026-74890 or the next vulnerability affects your stack