What’s Vulnerable › Vulnerabilities
CVE-2026-74892: openssl_encrypt before 1.4.0 Hardcoded Secret Key
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-17 · updated 2026-10-24
- Weakness: CWE-798
Description
openssl_encrypt versions before 1.4.0 contain a hardcoded default secret key in the standalone telemetry server configuration that is used for API key hashing. Attackers who know this default value can predict or forge API key hashes to compromise telemetry API authentication.
Affected products
- jahlives openssl_encrypt: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: jahlives openssl_encrypt 1.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-p926-6hjp-w9jw
- https://www.vulncheck.com/advisories/openssl-encrypt-before-hardcoded-secret-key
Get alerted when CVE-2026-74892 or the next vulnerability affects your stack