What’s Vulnerable › Vulnerabilities
CVE-2026-74896: openssl_encrypt before 1.4.0 Sandbox Escape via Dunder Attribute Traversal
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-17 · updated 2026-09-01
- Weakness: CWE-693
Description
openssl_encrypt versions before 1.4.0 contain a sandbox escape vulnerability in the DangerousPatternVisitor AST analyzer that fails to detect dunder attribute traversal techniques. Attackers can use __class__, __bases__, __subclasses__(), and __globals__ chains to access restricted functions and execute arbitrary system commands from plugin code.
Affected products
- jahlives openssl_encrypt: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: jahlives openssl_encrypt 1.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-w7gr-9g4g-33mx
- https://www.vulncheck.com/advisories/openssl-encrypt-before-sandbox-escape-via-dunder-attribute-traversal
- https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-w7gr-9g4g-33mx
Get alerted when CVE-2026-74896 or the next vulnerability affects your stack