What’s Vulnerable › Vulnerabilities
CVE-2026-74899: openssl_encrypt before 1.4.0 Sandbox Escape via Type Hierarchy
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-17 · updated 2026-08-28
- Weakness: CWE-95
Description
openssl_encrypt versions before 1.4.0 contain a sandbox escape vulnerability in IsolatedPluginExecutor that exposes Python type objects in restricted exec() builtins. Attackers can traverse the Python class hierarchy via __class__.__mro__.__subclasses__() to access system functions and execute arbitrary OS commands.
Affected products
- jahlives openssl_encrypt: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: jahlives openssl_encrypt 1.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-m25m-ggxg-239c
- https://www.vulncheck.com/advisories/openssl-encrypt-before-sandbox-escape-via-type-hierarchy
- https://github.com/siyuan-note/siyuan/security/advisories/GHSA-43jx-gxq4-jpjc
Get alerted when CVE-2026-74899 or the next vulnerability affects your stack