What’s Vulnerable › Vulnerabilities
CVE-2026-74907: Grav before 2.0.15 Path Traversal via plugin-asset-map.php
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-18 · updated 2026-10-22
- Weakness: CWE-22
Description
Grav before 2.0.15 contains a path traversal vulnerability in the static asset server within index.php that uses string prefix matching instead of directory-boundary validation. Unauthenticated attackers can access files in sibling directories by exploiting directory names that extend the base path string, such as requesting assets-secret when assets is the configured base.
Affected products
- getgrav grav: before 2.0.15 — fixed in 2.0.15
How to fix
Upgrade to a fixed version: getgrav grav 2.0.15. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-4v9q-p283-qc2m
- https://www.vulncheck.com/advisories/grav-before-path-traversal-via-plugin-asset-map-php
Get alerted when CVE-2026-74907 or the next vulnerability affects your stack