What’s Vulnerable › Vulnerabilities
CVE-2026-7505: nextlevelbuilder GoClaw/GoClaw Lite RPC improper authorization
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-30 · updated 2026-10-26
- Weakness: CWE-266
Description
A flaw has been found in nextlevelbuilder GoClaw and GoClaw Lite up to 3.8.5. This affects an unknown function of the component RPC Handler. This manipulation causes improper authorization. The attack may be initiated remotely. The exploit has been published and may be used. Upgrading to version 3.9.0 mitigates this issue. Patch name: 406022e79f4a18b3070a446712080571eff11e30. You should upgrade the affected component.
Affected products
- nextlevelbuilder GoClaw: 3.8.0, 3.8.1, 3.8.2, 3.8.3, 3.8.4, 3.8.5
- nextlevelbuilder GoClaw Lite: 3.8.0, 3.8.1, 3.8.2, 3.8.3, 3.8.4, 3.8.5
References
- https://github.com/nextlevelbuilder/goclaw/
- https://github.com/nextlevelbuilder/goclaw/commit/406022e79f4a18b3070a446712080571eff11e30
- https://github.com/nextlevelbuilder/goclaw/issues/866
- https://github.com/nextlevelbuilder/goclaw/pull/950
- https://github.com/nextlevelbuilder/goclaw/releases/tag/v3.9.0
- https://vuldb.com/submit/803458
- https://vuldb.com/vuln/360314
- https://vuldb.com/vuln/360314/cti
Get alerted when CVE-2026-7505 or the next vulnerability affects your stack