What’s Vulnerable › Vulnerabilities
CVE-2026-7507: Org.keycloak/keycloak-services: session fixation in oidc login flow that can lead to account takeover
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-19 · updated 2026-10-26
- Weakness: CWE-290
Description
A session fixation vulnerability was found in Keycloak's login-actions endpoints. An unauthenticated attacker could exploit this flaw by pre-creating an authentication session and tricking a victim into visiting a maliciously crafted link. By leveraging the /login-actions/restart endpoint—which processes session handles without adequate CSRF protection or cookie ownership validation—an attacker can reset the authentication flow state. This causes Single Sign-On (SSO) to authenticate the victim transparently upon clicking the link, allowing the attacker to hijack the required-action form without needing the victim's credentials. A successful exploit could lead to complete account takeover, including highly privileged administrative accounts.
Affected products
- Red Hat build of Keycloak 26.4: from 26.4 before 26.4.12 — fixed in 26.4.12
How to fix
Upgrade to a fixed version: Red Hat build of Keycloak 26.4 26.4.12. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2026:19594
- https://access.redhat.com/errata/RHSA-2026:19595
- https://access.redhat.com/errata/RHSA-2026:19596
- https://access.redhat.com/errata/RHSA-2026:19597
- https://access.redhat.com/errata/RHSA-2026:76128
- https://access.redhat.com/errata/RHSA-2026:76129
- https://access.redhat.com/errata/RHSA-2026:76130
- https://access.redhat.com/errata/RHSA-2026:76132
- https://access.redhat.com/errata/RHSA-2026:76134
- https://access.redhat.com/security/cve/CVE-2026-7507
- https://bugzilla.redhat.com/show_bug.cgi?id=2464145
- https://access.redhat.com/errata/RHSA-2026:19594
Get alerted when CVE-2026-7507 or the next vulnerability affects your stack