What’s Vulnerable › Vulnerabilities
CVE-2026-75107: Grav Form Plugin before 9.1.19 Stored XSS via Field Properties
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-18 · updated 2026-10-22
- Weakness: CWE-79
Description
Grav Form Plugin before 9.1.19 fails to escape field-definition properties including prepend, append, spacer text, section text, and select option labels in form templates. Attackers with form authoring privileges can inject arbitrary HTML and JavaScript that executes for all form visitors through unescaped |raw filters and unquoted attributes.
Affected products
- getgrav grav: before 9.1.19 — fixed in 9.1.19
How to fix
Upgrade to a fixed version: getgrav grav 9.1.19. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-5jrr-wfgh-mhg9
- https://www.vulncheck.com/advisories/grav-form-plugin-before-stored-xss-via-field-properties
- https://github.com/getgrav/grav/security/advisories/GHSA-5jrr-wfgh-mhg9
Get alerted when CVE-2026-75107 or the next vulnerability affects your stack