What’s Vulnerable › Vulnerabilities
CVE-2026-75124: PLANET GS-4210-16P2S V3 Memory Corruption via dispatcher.cgi _readHttpParam
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-28 · updated 2026-09-08
- Weakness: CWE-120
Description
PLANET GS-4210-16P2S V3 firmware before 3.441b260626 contains a pre-authentication memory corruption vulnerability in the web management interface where the _readHttpParam function copies an oversized HTTP query string without guaranteeing NUL termination, allowing parse_query_string to process attacker-controlled data into a fixed-size stack buffer. An unauthenticated remote attacker can send an oversized GET request to dispatcher.cgi to cause denial of service of the web management interface and potentially trigger memory corruption.
Affected products
- PLANET Technology Corp. PLANET GS-4210-16P2S V3: before 3.441b260626 — fixed in 3.441b260626
How to fix
Upgrade to a fixed version: PLANET Technology Corp. PLANET GS-4210-16P2S V3 3.441b260626. Check the vendor advisory for mitigations.
References
- https://www.planet.com.tw/en/support/security-advisory/10
- https://www.vulncheck.com/advisories/planet-gs-4210-16p2s-memory-corruption-via-dispatcher-cgi-readhttpparam
Get alerted when CVE-2026-75124 or the next vulnerability affects your stack