What’s Vulnerable › Vulnerabilities

CVE-2026-7541: Denial of service vulnerability in GitHub Enterprise Server allowed service disruption via unauthenticated API endpoint

Description

A denial of service vulnerability was identified in GitHub Enterprise Server that allowed an unauthenticated attacker to cause service disruption by sending crafted requests with deeply nested JSON payloads to an unauthenticated API endpoint. The endpoint parsed user-controlled JSON request bodies without size or depth limits, causing excessive CPU and memory consumption. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.21 and was fixed in versions 3.20.2, 3.19.6, 3.18.9, 3.17.15, and 3.16.18. This vulnerability was reported via the GitHub Bug Bounty program.

Affected products

How to fix

Upgrade to a fixed version: GitHub Enterprise Server 3.16.18, 3.17.15, 3.18.9, 3.19.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-7541 or the next vulnerability affects your stack