What’s Vulnerable › Vulnerabilities
CVE-2026-75486: Synk Sweater Comb < 3.8.8 Command Injection via .vervet.yaml Branch Name
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-28 · updated 2026-09-08
- Weakness: CWE-78
Description
Synk Sweater Comb before 3.8.8 contains a command injection vulnerability that allows an attacker who controls the .vervet.yaml configuration file to execute arbitrary OS commands by injecting malicious input into the linters.<key>.optic-ci.original branch name field. The expectGitBranch() function in src/lint.ts passes the unsanitized branch name directly into child_process.exec() via an unescaped template literal, enabling arbitrary command execution when the lint command is run against the repository.
Affected products
- snyk sweater-comb: before 3.8.8 — fixed in 3.8.8
How to fix
Upgrade to a fixed version: snyk sweater-comb 3.8.8. Check the vendor advisory for mitigations.
References
- https://github.com/snyk/sweater-comb/commit/05a0eec4f2acb9ce6d4814016b475504fc64eab2
- https://github.com/snyk/sweater-comb/pull/743
- https://github.com/snyk/sweater-comb/releases/tag/v3.8.8
- https://www.vulncheck.com/advisories/synk-sweater-comb-command-injection-via-vervet-yaml-branch-name
- https://github.com/snyk/sweater-comb/pull/743
Get alerted when CVE-2026-75486 or the next vulnerability affects your stack