What’s Vulnerable › Vulnerabilities
CVE-2026-75758: Unbounded recursion between Inspect.List charlist rendering and List.to_string/1 error path in Elixir
- Severity: medium (CVSS 5.9 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-28 · updated 2026-09-01
- Weakness: CWE-674
Description
Uncontrolled Recursion vulnerability in the Elixir standard library allows an attacker who controls a list passed to inspect/1, List.to_string/1, or List.to_charlist/1 to exhaust a BEAM node's memory. Inspect.List's charlist branch in lib/elixir/lib/inspect.ex classifies a list as a charlist using List.ascii_printable?/2, which examines only the first :printable_limit (4096 by default) elements, and then calls IO.chardata_to_string/1 on the whole term. A list whose printable prefix exceeds that limit but which contains a later element that is not a code point (an atom, an out-of-range integer, or an improper tail) is therefore mis-classified, and the conversion raises ArgumentError. That conversion runs inside List.to_string/1, whose rescue clause builds its message by interpolating inspect(list), which re-enters the same branch and raises again. The nested inspection is an argument to raise, so the recursion is not in tail position and every level is retained: the process stack grows monotonically while each cycle re-walks the list, until the process is killed by max_heap_size or, by default, the node runs out of memory. List.to_charlist/1 has the same rescue shape. Below the printable limit the inner inspect/1 sees the invalid element within its counter and renders the list in ordinary bracket form, so a single ArgumentError is raised and no recursion occurs. This issue affects elixir: from 1.15.0-rc.0 before 1.18.5, from 1.19.0-rc.0 before 1.19.6, and from 1.20.0-rc.0 before 1.20.4.
Affected products
- elixir-lang elixir: from 1.15.0-rc.0 before 1.18.5; from 1.19.0-rc.0 before 1.19.6; from 1.20.0-rc.0 before 1.20.4 — fixed in 1.18.5, 1.19.6, 1.20.4
How to fix
Upgrade to a fixed version: elixir-lang elixir 1.18.5, 1.19.6, 1.20.4. Check the vendor advisory for mitigations.
References
- https://cna.erlef.org/cves/CVE-2026-75758.html
- https://github.com/elixir-lang/elixir/commit/0bba5887577b1e328da825bd018815fdc519685a
- https://github.com/elixir-lang/elixir/commit/1eff1acffd49bdcc0d7f57ca74c1603328eed68a
- https://github.com/elixir-lang/elixir/commit/5230d73968f1b4969d2a2646786fa6c71475f5cc
- https://github.com/elixir-lang/elixir/commit/a983c8c043b1fbf1d95df78a29149222dac2988c
- https://github.com/elixir-lang/elixir/security/advisories/GHSA-jf5q-v438-665c
- https://osv.dev/vulnerability/EEF-CVE-2026-75758
- https://github.com/elixir-lang/elixir/security/advisories/GHSA-jf5q-v438-665c
Get alerted when CVE-2026-75758 or the next vulnerability affects your stack