What’s Vulnerable › Vulnerabilities
CVE-2026-75797: AI Engine 3.3.3 - 3.7.1 - Subscriber+ Arbitrary File Read via 'url' Parameter
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-26 · updated 2026-08-26
- Weakness: CWE-22
Description
The AI Engine WordPress plugin before 3.7.2 does not confine a caller-supplied URL when mapping it to a local filesystem path before reading the file and forwarding its contents to an external service, allowing users with a subscriber-level account to read arbitrary files from the server and exfiltrate them off-host. Reaching the issue at subscriber level requires a non-default public API feature to be enabled; otherwise the same issue is reachable by an administrator, which on multisite allows a non-super subsite administrator to read the network-shared configuration and its secrets.
Affected products
- AI Engine: from 3.3.3 before 3.7.2 — fixed in 3.7.2
How to fix
Upgrade to a fixed version: AI Engine 3.7.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-75797 or the next vulnerability affects your stack