What’s Vulnerable › Vulnerabilities
CVE-2026-75806: Unauthenticated and Undersized DTLS 1.2 AEAD Record Causes DoS
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-29 · updated 2026-10-08
- Weakness: CWE-1284
Description
Issue summary: An established DTLS 1.2 association using an AEAD cipher suite can be terminated by a single unauthenticated datagram whose encrypted fragment is shorter than the mandatory explicit IV and authentication tag overhead. Impact summary: An attacker who can send a datagram that is routed to an existing DTLS 1.2 association can tear that association down without knowing any key material. This is a Denial of Service limited to the targeted association. There is no memory safety or confidentiality impact. CWE: CWE-1284: Improper Validation of Specified Quantity in Input Description: In TLS 1.2 and DTLS 1.2 every record protected by an AEAD cipher suite carries an explicit IV followed by the ciphertext and an authentication tag. When decrypting such a record the record layer passed the record length to the cipher implementation before checking that the record was long enough to contain the explicit IV and the tag. For a record shorter than that overhead the cipher implementation rejected the impossible length, and the record layer treated this as an internal failure and raised a fatal internal_error alert instead of treating the record as one that failed authentication. In TLS 1.2 the same record causes a fatal internal_error alert instead of the expected bad_record_mac alert. Since any undecryptable record already terminates a TLS connection, this is a protocol conformance issue rather than a security issue in TLS. The fix validates the record length against the explicit IV and tag length before any AEAD processing, so that TLS reports bad_record_mac and DTLS silently discards the record. FIPS impact: no The affected code is outside the FIPS module boundary.
Affected products
- OpenSSL: from 1.1.1 before 1.1.1zj; from 3.0.0 before 3.0.23; from 3.4.0 before 3.4.8; from 3.5.0 before 3.5.9; from 3.6.0 before 3.6.5; from 4.0.0 before 4.0.3 — fixed in 1.1.1zj, 3.0.23, 3.4.8, 3.5.9, 3.6.5, 4.0.3
How to fix
Upgrade to a fixed version: OpenSSL 1.1.1zj, 3.0.23, 3.4.8, 3.5.9. Check the vendor advisory for mitigations.
References
- https://github.com/openssl/openssl/commit/04728a289a823e68137f88da016cb9ede307217d
- https://github.com/openssl/openssl/commit/050b275cd671a6eed1d6457642d41a5a77aab972
- https://github.com/openssl/openssl/commit/3a4589d015a9049d47b66f186cf50a8711343a1d
- https://github.com/openssl/openssl/commit/5af82fefbaf2b5fec2fc0e1d87f112844902f01d
- https://openssl-library.org/news/secadv/20260929.txt
Get alerted when CVE-2026-75806 or the next vulnerability affects your stack