What’s Vulnerable › Vulnerabilities
CVE-2026-75818: Heap Buffer Overflow in GNU Aspell's prezip utility
- Severity: low (CVSS 1.8 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-06 · updated 2026-10-06
- Weakness: CWE-122
Description
GNU Aspell prezip-bin contains a heap-based buffer overflow vulnerability in the decompressor in prog/prezip.c. The decompressor does not properly check buffer space, so a crafted compressed file can cause out-of-bounds read and write operations on the heap. An attacker who convinces a user to process a malicious compressed file with prezip-bin can trigger memory corruption, leading to a processs crash. This issue was fixed in commit 15b188437f9e0192d4ac4472ad66a4e2f62a782f which will be released in version 0.60.8.3.
Affected products
- GNU Aspell: before 0.60.8.3 — fixed in 0.60.8.3
How to fix
Upgrade to a fixed version: GNU Aspell 0.60.8.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-75818 or the next vulnerability affects your stack