What’s Vulnerable › Vulnerabilities
CVE-2026-75819: Out-of-bounds Read in GNU Aspell
- Severity: low (CVSS 1.8 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-06 · updated 2026-10-06
- Weakness: CWE-125
Description
GNU Aspell contains an out-of-bounds read vulnerability in ReadOnlyDict::load() in readonly_ws.cpp. When loading a binary .rws dictionary file, it uses offset fields from the file header as byte indices into a heap buffer without validating their bounds. An attacker can trigger this by convincing a user to run aspell with a crafted dictionary file supplied through --master, --dict-dir, or configuration options, leading to heap memory disclosure or a denial of service via application crash. This issue was fixed in commit 941953b25031bc9104e83f58e138a664b8dedc3f which will be released in version 0.60.8.3.
Affected products
- GNU Aspell: before 0.60.8.3 — fixed in 0.60.8.3
How to fix
Upgrade to a fixed version: GNU Aspell 0.60.8.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-75819 or the next vulnerability affects your stack