What’s Vulnerable › Vulnerabilities
CVE-2026-75820: Integer Truncation Leading to Heap Corruption in GNU Aspell
- Severity: low (CVSS 1.8 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-06 · updated 2026-10-06
- Weakness: CWE-190
Description
GNU Aspell contains an integer truncation vulnerability in the WritableDict::add() function in modules/speller/default/writable.cpp. When loading a personal wordlist, the word length is stored as a single byte, causing truncation for words whose length is a multiple of 256. This leads to heap corruption. An attacker can exploit this by convincing a user to run aspell with a crafted personal wordlist containing such a word, resulting in denial of service. This issue was fixed in commit 782ce94e4dc71eaec4ee1bd945eb3b9c47c5387d which will be released in version 0.60.8.3.
Affected products
- GNU Aspell: before 0.60.8.3 — fixed in 0.60.8.3
How to fix
Upgrade to a fixed version: GNU Aspell 0.60.8.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-75820 or the next vulnerability affects your stack