What’s Vulnerable › Vulnerabilities
CVE-2026-75823: WP User Frontend 3.5.29 - 4.3.11 - Unauthenticated Privilege Escalation via Registration Role Encryption
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-30 · updated 2026-09-30
- Weakness: CWE-269
Description
The User Frontend WordPress plugin before 4.3.12 does not prevent tampering with the role assigned by its registration form, allowing unauthenticated users to register with a higher privileged role, such as Editor. This affects installations running a PHP build where the sodium extension is unavailable, and where a registration page has been configured. The administrator role cannot be obtained this way.
Affected products
- User Frontend: from 3.5.29 before 4.3.12 — fixed in 4.3.12
How to fix
Upgrade to a fixed version: User Frontend 4.3.12. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-75823 or the next vulnerability affects your stack