What’s Vulnerable › Vulnerabilities
CVE-2026-75827: Grav before 2.0.15 Arbitrary File Write via error_log
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-18 · updated 2026-10-22
- Weakness: CWE-94
Description
Grav before 2.0.15 contains an arbitrary file write vulnerability in the Blueprint dynamic-data bare-function validation that uses an incomplete denylist instead of a positive allowlist. Attackers with page-edit or blueprint-config access can invoke the error_log function through a data directive to append PHP payloads to web-accessible files, achieving remote code execution.
Affected products
- getgrav grav: before 2.0.15 — fixed in 2.0.15
How to fix
Upgrade to a fixed version: getgrav grav 2.0.15. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-f8wv-xp27-6gq7
- https://www.vulncheck.com/advisories/grav-before-arbitrary-file-write-via-error-log
- https://github.com/getgrav/grav/security/advisories/GHSA-f8wv-xp27-6gq7
Get alerted when CVE-2026-75827 or the next vulnerability affects your stack