What’s Vulnerable › Vulnerabilities
CVE-2026-75828: Grav before 2.0.15 Stored XSS via detectXss() Quote Bypass
- Severity: high (CVSS 8.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-18 · updated 2026-10-22
- Weakness: CWE-79
Description
Grav before 2.0.15 contains a stored cross-site scripting vulnerability in the detectXss() function where unpaired quotes in unquoted attribute values bypass event-handler detection. Authenticated editors can inject event handlers like onerror= that pass validation and execute in visitor browsers when page content is rendered.
Affected products
- getgrav grav: before 2.0.15 — fixed in 2.0.15
How to fix
Upgrade to a fixed version: getgrav grav 2.0.15. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-vfmf-q6x9-cw96
- https://www.vulncheck.com/advisories/grav-before-stored-xss-via-detectxss-quote-bypass
- https://github.com/getgrav/grav/security/advisories/GHSA-vfmf-q6x9-cw96
Get alerted when CVE-2026-75828 or the next vulnerability affects your stack