What’s Vulnerable › Vulnerabilities
CVE-2026-75829: grav-plugin-api before 1.0.15 Twig SSTI via translate endpoint
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-18 · updated 2026-10-22
- Weakness: CWE-1336
Description
grav-plugin-api versions before 1.0.15 fail to validate Twig content in the translate() endpoint, allowing attackers with api.pages.write permission to persist pages with process.twig enabled. Attackers can submit crafted header and content parameters to execute server-side template injection payloads that are evaluated at render time.
Affected products
- getgrav grav: before 1.0.15 — fixed in 1.0.15
How to fix
Upgrade to a fixed version: getgrav grav 1.0.15. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-w94c-jmg4-w4c9
- https://www.vulncheck.com/advisories/grav-plugin-api-before-twig-ssti-via-translate-endpoint
Get alerted when CVE-2026-75829 or the next vulnerability affects your stack