What’s Vulnerable › Vulnerabilities

CVE-2026-75830: grav-plugin-api before 1.0.15 Path Traversal via batchCopy

Description

grav-plugin-api (getgrav/grav-plugin-api) versions >= 1.0.0-beta.10 and <= 1.0.14 contain a path traversal vulnerability in the PagesController::batchCopy() method. An incomplete fix for GHSA-qjq4-jp55-4mx2 left the user-controlled 'suffix' parameter (via POST /api/v1/pages/batch) unvalidated. An authenticated user with the api.pages.write permission (editor-level, not super-admin) can supply path traversal sequences (e.g. /../../../) in the suffix parameter to escape the intended user/pages/ directory and write attacker-controlled page content and page media to arbitrary filesystem locations writable by the web server process. The vulnerability is fixed in 1.0.15.

Affected products

How to fix

Upgrade to a fixed version: getgrav grav 1.0.15. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-75830 or the next vulnerability affects your stack