What’s Vulnerable › Vulnerabilities
CVE-2026-75832: Grav API Plugin before 1.0.14 Authorization Bypass
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-18 · updated 2026-10-22
- Weakness: CWE-862
Description
The Grav API plugin (getgrav/grav-plugin-api, bundled with Grav 2.0) before version 1.0.14 (fixed in 1.0.15) contains a missing authorization vulnerability in BlueprintPathResolver::resolveUserScope(). The method gates the users/<name> scope on the account's raw super-admin ACL flag (access.api.super) instead of validating the presented API key's actual scope. An attacker holding an API key scoped only to api.media.write minted on a super-admin account can bypass the authorization check and, via POST /blueprint-upload or GET /blueprint-files, write a file into another user's scope (in the shared user/accounts/ directory, constrained to image extensions by assertSafeExtension()) and browse that scope's file listing, despite the key not being granted api.users.write.
Affected products
- getgrav grav: before 1.0.14 — fixed in 1.0.14
How to fix
Upgrade to a fixed version: getgrav grav 1.0.14. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-435x-66r2-jwv2
- https://www.vulncheck.com/advisories/grav-api-plugin-before-authorization-bypass
Get alerted when CVE-2026-75832 or the next vulnerability affects your stack