What’s Vulnerable › Vulnerabilities
CVE-2026-75834: Grav before 2.0.14 Stored XSS via Invalid UTF-8 Byte
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-18 · updated 2026-10-22
- Weakness: CWE-79
Description
Grav before 2.0.14 contains a stored cross-site scripting vulnerability in the Security::detectXss() function (system/src/Grav/Common/Security.php). All XSS detection patterns use the PCRE /u (UTF-8) modifier, so a single invalid UTF-8 byte anywhere in page content causes preg_match() to return false for every pattern, silently bypassing the save-time XSS safety gate (Validation::checkSafety()). An authenticated attacker with page-edit permissions (without the security.xss_whitelist privilege) can store malicious JavaScript that executes in the browser of a visitor who views the affected page.
Affected products
- getgrav grav: before 2.0.14 — fixed in 2.0.14
How to fix
Upgrade to a fixed version: getgrav grav 2.0.14. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-q2j8-x8hf-63ch
- https://www.vulncheck.com/advisories/grav-before-stored-xss-via-invalid-utf-8-byte
Get alerted when CVE-2026-75834 or the next vulnerability affects your stack