What’s Vulnerable › Vulnerabilities
CVE-2026-75835: Grav API Plugin before 1.0.14 Missing Authorization
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-18 · updated 2026-10-22
- Weakness: CWE-862
Description
Grav API plugin (getgrav/grav-plugin-api) before 1.0.14 contains a missing authorization vulnerability in userPassesAuthorize() (AbstractApiController.php). The function fails to consult the calling request's API key scopes, relying instead on the account's raw super-admin flag and ACL grants. As a result, an authenticated attacker holding a scoped API key minted on a privileged account can bypass their declared scope restrictions to access authorize-gated UI metadata and item definitions (sidebar/menubar/widget items and users-list columns/row-actions/filter-tabs) that their key scope should deny, resulting in information disclosure.
Affected products
- getgrav grav: before 1.0.14 — fixed in 1.0.14
How to fix
Upgrade to a fixed version: getgrav grav 1.0.14. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-p57v-xhv3-mf2w
- https://www.vulncheck.com/advisories/grav-api-plugin-before-missing-authorization
- https://github.com/getgrav/grav/security/advisories/GHSA-p57v-xhv3-mf2w
Get alerted when CVE-2026-75835 or the next vulnerability affects your stack