What’s Vulnerable › Vulnerabilities
CVE-2026-75836: Grav API Plugin before 1.0.14 Missing Authorization
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-18 · updated 2026-10-22
- Weakness: CWE-862
Description
The Grav API plugin (getgrav/grav-plugin-api, bundled with Grav's admin-next/API stack) before 1.0.14 fails to enforce the authorize requirement in MenubarController::executeAction(). While the GET /menubar/items listing endpoint correctly filters menubar items via userPassesAuthorize(), the POST /api/v1/menubar/actions/{plugin}/{action} endpoint only checks the baseline api.access permission and never evaluates the authorize field a plugin registered for that action. Any authenticated caller with api.access can therefore invoke a privileged menubar action directly, bypassing the intended authorization. No plugin bundled with core Grav currently registers a privileged authorize handler, so on a stock install the impact is latent; the flaw affects any first- or third-party plugin relying on the documented authorize semantics.
Affected products
- getgrav grav: before 1.0.14 — fixed in 1.0.14
How to fix
Upgrade to a fixed version: getgrav grav 1.0.14. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-8mjx-xjfv-9c88
- https://www.vulncheck.com/advisories/grav-api-plugin-before-missing-authorization-2
- https://github.com/getgrav/grav/security/advisories/GHSA-8mjx-xjfv-9c88
Get alerted when CVE-2026-75836 or the next vulnerability affects your stack