What’s Vulnerable › Vulnerabilities
CVE-2026-75843: ArcadeDB before 26.8.1 Privilege Escalation via gRPC Transaction
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-18 · updated 2026-10-22
- Weakness: CWE-269
Description
ArcadeDB before 26.8.1 fails to bind the authenticated principal on the gRPC transaction executor thread in beginTransaction, allowing authenticated readers to execute JavaScript commands without scripting authorization checks. Attackers can execute executeCommand with a transaction ID to run unrestricted JavaScript that creates server-wide administrator accounts.
Affected products
- ArcadeData arcadedb: before 26.8.1 — fixed in 26.8.1
How to fix
Upgrade to a fixed version: ArcadeData arcadedb 26.8.1. Check the vendor advisory for mitigations.
References
- https://github.com/ArcadeData/arcadedb/security/advisories/GHSA-p29f-345w-4qwf
- https://www.vulncheck.com/advisories/arcadedb-before-privilege-escalation-via-grpc-transaction
- https://github.com/ArcadeData/arcadedb/security/advisories/GHSA-p29f-345w-4qwf
Get alerted when CVE-2026-75843 or the next vulnerability affects your stack