What’s Vulnerable › Vulnerabilities
CVE-2026-75845: ArcadeDB 26.4.2 before 26.8.1 Authorization Bypass via set_server_setting
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-18 · updated 2026-10-22
- Weakness: CWE-269
Description
ArcadeDB versions 26.4.2 through 26.7.3 contain an authorization bypass vulnerability in the set_server_setting MCP server-level tool. SetServerSettingTool.execute() gates only on the global allowAdmin flag and never checks the caller's role, so in an MCP deployment with allowAdmin=true and a non-root allowedUsers set, any authenticated read-only user can invoke set_server_setting to modify server GlobalConfiguration, enabling configuration tampering or denial of service. The issue is fixed in 26.8.1.
Affected products
- ArcadeData arcadedb: from 26.4.2 before 26.8.1 — fixed in 26.8.1
How to fix
Upgrade to a fixed version: ArcadeData arcadedb 26.8.1. Check the vendor advisory for mitigations.
References
- https://github.com/ArcadeData/arcadedb/security/advisories/GHSA-pff6-hp53-pj54
- https://www.vulncheck.com/advisories/arcadedb-before-authorization-bypass-via-set-server-setting
- https://github.com/ArcadeData/arcadedb/security/advisories/GHSA-pff6-hp53-pj54
Get alerted when CVE-2026-75845 or the next vulnerability affects your stack