What’s Vulnerable › Vulnerabilities
CVE-2026-75858: CodeWhale rlm_eval before 0.8.64 Remote Code Execution
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-18 · updated 2026-10-22
- Weakness: CWE-94
Description
CodeWhale (packages codewhale / codewhale-tui) versions >= 0.8.41 and < 0.8.64 contain a remote code execution vulnerability in the rlm_eval tool. The tool's approval_requirement() returns ApprovalRequirement::Auto, which the engine treats as 'never prompt,' causing arbitrary model-supplied Python code to run in a python3 interpreter without consulting the user's configured --approval-policy and without any approval prompt or audit step. An attacker can induce the agent to execute arbitrary code via prompt injection in untrusted content the agent reads (a web page, fetched URL, repository file, or MCP tool result); the companion rlm_open tool can stage such content. Code runs on the user's machine at the user's privilege level. Fixed in 0.8.64.
Affected products
- Hmbown CodeWhale: from 0.8.33 before 0.8.41; from 0.8.41 before 0.8.64 — fixed in 0.8.41, 0.8.64
How to fix
Upgrade to a fixed version: Hmbown CodeWhale 0.8.41, 0.8.64. Check the vendor advisory for mitigations.
References
- https://github.com/Hmbown/CodeWhale/commit/57f3c89471e27ac4032d9791f6885e5d4408c381
- https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-wrj3-vj8c-784f
- https://www.vulncheck.com/advisories/codewhale-rlm-eval-before-remote-code-execution
- https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-wrj3-vj8c-784f
Get alerted when CVE-2026-75858 or the next vulnerability affects your stack