What’s Vulnerable › Vulnerabilities
CVE-2026-75859: CodeWhale before 0.8.64 Arbitrary File Read via instructions
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-18 · updated 2026-10-22
- Weakness: CWE-22
Description
CodeWhale versions before 0.8.64 fail to validate file paths in the project config instructions field, allowing attackers to read arbitrary files on the victim's system. A malicious .codewhale/config.toml file in a cloned repository can specify paths outside the workspace that are read and injected into the AI system prompt for exfiltration.
Affected products
- Hmbown CodeWhale: from 0.8.8 before 0.8.41; from 0.8.41 before 0.8.64 — fixed in 0.8.41, 0.8.64
How to fix
Upgrade to a fixed version: Hmbown CodeWhale 0.8.41, 0.8.64. Check the vendor advisory for mitigations.
References
- https://github.com/Hmbown/CodeWhale/commit/43563356b98c6b993085554da82e77370160a31c
- https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-62f5-cp2p-vq95
- https://www.vulncheck.com/advisories/codewhale-before-arbitrary-file-read-via-instructions
Get alerted when CVE-2026-75859 or the next vulnerability affects your stack