What’s Vulnerable › Vulnerabilities

CVE-2026-75880: Apache Artemis, Apache ActiveMQ Artemis: Message selector wildcard handling could lead to denial of service

Description

An authenticated client could attach a consumer with a selector containing crafted wildcard usage that results in excessive evaluation during message delivery attempts, occupying a shared broker thread and leading to denial of service. This issue affects Apache Artemis: from 2.50.0 through 2.56.0; Apache ActiveMQ Artemis: from 1.0.0 through 2.44.0. Users are recommended to upgrade to version 2.57.0, which fixes this issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache ActiveMQ Artemis 2.44.0, 2.57.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-75880 or the next vulnerability affects your stack