What’s Vulnerable › Vulnerabilities
CVE-2026-75893: Heap based buffer overflow at ipaccess_proxy_read_msg()
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-18 · updated 2026-09-21
- Weakness: CWE-122
Description
In osmo-bsc from 1.0.1 through 1.14.1 a heap based buffer overflow issue was found in the ipaccess_proxy_read_msg() function via IPA frame lengths.
Affected products
- Osmocom osmo-bsc: from 1.0.1 before 1.14.1 — fixed in 1.14.1
How to fix
Upgrade to a fixed version: Osmocom osmo-bsc 1.14.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-75893 or the next vulnerability affects your stack