What’s Vulnerable › Vulnerabilities
CVE-2026-75899: fast-uri vulnerable to server-side request forgery via repeated hostname percent-decoding
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-24 · updated 2026-10-14
- Weakness: CWE-174
Description
fast-uri is a URI parser for Node.js. It decodes percent escapes in a hostname during parsing and then decodes the parsed hostname a second time during authority recomposition, so a single call to normalize or resolve can turn nested percent-encoded input into a different network destination such as a loopback hostname or address. For example, a doubly encoded host that spells out a loopback name decodes to that live host in one operation, which contradicts RFC 3986 section 2.4 that an implementation must not decode the same string more than once. An application that normalizes or resolves an untrusted HTTP-family URI before outbound routing, redirect validation, or a host-policy check can receive a destination different from the one the original encoded host represented, giving a server-side request forgery and host-policy bypass primitive. This is an incomplete-fix variant of CVE-2026-6322. The affected versions are 2.4.1 up to but not including 2.4.5, 3.1.2 up to but not including 3.1.6, and 4.0.0 up to but not including 4.1.3. The issue is fixed in 2.4.5, 3.1.6, and 4.1.3, which normalize percent escapes once and preserve encoded percent signs. Users should upgrade to a patched version.
Affected products
- fast-uri: from 2.4.1 before 2.4.5; from 3.1.2 before 3.1.6; from 4.0.0 before 4.1.3 — fixed in 2.4.5, 3.1.6, 4.1.3
How to fix
Upgrade to a fixed version: fast-uri 2.4.5, 3.1.6, 4.1.3. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/fastify/fast-uri/security/advisories/GHSA-fph4-wmhf-6fwf
Get alerted when CVE-2026-75899 or the next vulnerability affects your stack