What’s Vulnerable › Vulnerabilities
CVE-2026-75911: CodeWhale before 0.8.64 Remote Code Execution via allow_shell
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-18 · updated 2026-10-22
- Weakness: CWE-94
Description
CodeWhale versions before 0.8.64 fail to properly validate the allow_shell configuration parameter from project config files, allowing attackers to enable arbitrary shell command execution by committing a malicious .codewhale/config.toml file to a repository. When a user clones and opens the repository in CodeWhale, the AI model gains access to exec_shell and task_shell tools, enabling execution of arbitrary shell commands on the victim's machine without explicit user consent.
Affected products
- Hmbown CodeWhale: from 0.8.6 before 0.8.41; from 0.8.41 before 0.8.64 — fixed in 0.8.41, 0.8.64
How to fix
Upgrade to a fixed version: Hmbown CodeWhale 0.8.41, 0.8.64. Check the vendor advisory for mitigations.
References
- https://github.com/Hmbown/CodeWhale/commit/43563356b98c6b993085554da82e77370160a31c
- https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-gx45-xrj5-g6c4
- https://www.vulncheck.com/advisories/codewhale-before-remote-code-execution-via-allow-shell
- https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-gx45-xrj5-g6c4
Get alerted when CVE-2026-75911 or the next vulnerability affects your stack