What’s Vulnerable › Vulnerabilities
CVE-2026-75912: CodeWhale before 0.8.64 Argument Injection via git_blame
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-18 · updated 2026-10-22
- Weakness: CWE-88
Description
CodeWhale versions before 0.8.64 contain an argument injection vulnerability in the git_blame tool that allows attackers to read arbitrary files by injecting git options into the unvalidated rev parameter. Attackers can supply rev values like --contents=/path/to/file to exfiltrate sensitive files such as SSH keys and credentials through the tool output returned to the model.
Affected products
- Hmbown CodeWhale: from 0.3.27 before 0.8.41; from 0.8.41 before 0.8.64 — fixed in 0.8.41, 0.8.64
How to fix
Upgrade to a fixed version: Hmbown CodeWhale 0.8.41, 0.8.64. Check the vendor advisory for mitigations.
References
- https://github.com/Hmbown/CodeWhale/commit/9a34b5034d29f05d1f28fa61b04719ca6a741020
- https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-c6mw-8xh8-gpq6
- https://www.vulncheck.com/advisories/codewhale-before-argument-injection-via-git-blame
- https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-c6mw-8xh8-gpq6
Get alerted when CVE-2026-75912 or the next vulnerability affects your stack