What’s Vulnerable › Vulnerabilities
CVE-2026-75919: phpMyFAQ before 4.1.7 Authentication Bypass via Setup API
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-19 · updated 2026-09-01
- Weakness: CWE-306
Description
phpMyFAQ before 4.1.7 contains an authentication bypass vulnerability in SetupController that allows unauthenticated attackers to run database migrations and create configuration backups when maintenance mode is enabled. Attackers can call POST /api/setup/update-database and POST /api/setup/backup endpoints to execute database updates, disable maintenance mode, and extract database credentials from generated ZIP archives.
Affected products
- thorsten phpMyFAQ: before 4.1.7 — fixed in 4.1.7
How to fix
Upgrade to a fixed version: thorsten phpMyFAQ 4.1.7. Check the vendor advisory for mitigations.
References
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-f96w-7fx2-79c8
- https://www.vulncheck.com/advisories/phpmyfaq-before-authentication-bypass-via-setup-api
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-f96w-7fx2-79c8
Get alerted when CVE-2026-75919 or the next vulnerability affects your stack